MSFS dh-89 Dragon Rapide
Page 1 of 2 12 LastLast
Results 1 to 25 of 27

Thread: MSFS dh-89 Dragon Rapide

  1. #1

    MSFS dh-89 Dragon Rapide


    A new entry has been added to Add-Ons Library, category FS 2020 - Civilian Props

    Description: MSFS native conversion of my dh-89 Dragon Rapide.

    To check it out, rate it or add comments, visit MSFS dh-89 Dragon Rapide
    The comments you make there will appear in the posts below.

  2. #2
    Dave - you're a real f-sim superstar!!!! Always great to see your work appearing - especially now for MSFS!!
    XP11.50 | MSFS 2020
    Intel Core i7 2600K @ 3.40-4.69GHz | 8GB DDR3 | nVidia RTX2060 8GB | Win10 2004 64-bit 24Gb RAM



  3. #3
    Thank You!
    Webmaster of yoyosims.pl.

    Win 10 64, i9 13900 KF, RTX 3090 24Gb, RAM32Gb, SSD M.2 NVMe, Predator XB271HU res.2560x1440 27'' G-sync, Sound Blaster Z + 5.1, TiR5 [MSFS, P3Dv5, DCS, RoF, Condor, IL-2 CoD/BoX] VR fly only: HP Reverb G2

  4. #4
    Looks beautiful , thank you very much .

  5. #5
    SOH-CM-2021
    Join Date
    Oct 2005
    Location
    Ringgold, Virginia, United States
    Age
    76
    Posts
    5,383

    Just Oh WOW!

    One of my faves, thanks Fave and Pam!

    Cazzie

  6. #6

    Rapide

    My favourite, too: Can't you just see "Mosquito" in those wings?

    . . .and here's a smaller version: Built in 1985 (when I had hair . .) 8' span. Not Gypsy Queens, but 2 x Saito 50's.

    https://1drv.ms/u/s!AueVg7eVAeXMlESo...UuWVS?e=pNfgeE

    Taking the snow shot is the original pilot - Capt. W.C. ("Bill") Boyes (retired Sr. Capt. Air Canada)

    pj



    i7-4790K@4.8 gig, using EK-Supreme HF waterblock, LG 43" 4K; MSI 2060; 32 gig G.Skill Trident GTX @2400; Win 10-64; Homebuilt cockpit; MD-80-style throttle quadrant; TrackIR5

  7. #7
    Dave, thank you so much for your efforts in building and converting this! Beautiful plane.

  8. #8

    Icon26

    Stunning.
    Many thanks for taking the time & trouble to create this.
    T43

  9. #9
    Thanks again for porting this beauty over to MSFS!

    One small problem: on a manual/cold & dark start, is the only way to start the engines CTRL-E (the old FSX hack)? I can power them up and get the starter turning over without it, but they just won't fire. I'm wondering whether the mixture is properly initialised to full/rich, as the lever animation doesn't quite seem to work.

    I expect it's an FSX-MSFS portover limitation, but you never know!

    P.S. I tried to post a comment+rating, but it wouldn't accept it - even though I was properly logged in.

    EDIT/UPDATE: Sorreeee ... user error!! Just spotted that I'd been forgetting to flip the two little cut-off levers either side of the cockpit ... DUH!!!!
    XP11.50 | MSFS 2020
    Intel Core i7 2600K @ 3.40-4.69GHz | 8GB DDR3 | nVidia RTX2060 8GB | Win10 2004 64-bit 24Gb RAM



  10. #10

    Re: MSFS dh-89 Dragon Rapide

    Comment:

    Download for me it is not possible. Can you check the link? thanks

    To check this out, and rate it or add your own comments, visit MSFS dh-89 Dragon Rapide.
    The comments you make there will appear in the posts below.

  11. #11
    Dave! I have a feecher/request for you!

    For some reason, I'm finding that the idling speed is pegged out at just over 1,000rpm - even though my throttle is fully back (confirmed in the MSFS outside view). It's all too easy to pitch up onto your nose when engaging/disengaging the parking brake (or when cheating by going in and out of SLEW mode). With brakes off, the Rapide starts moving fairly sharp-ish. I know some aircraft will taxi at idle (notably the A320) but this does seem a bit excessive.

    I've cast my eyes over aircraft.cfg and engines.cfg but my brain instantly fogged over - despite (or because of) various confusing Google searches.

    Any ideas?

    Either way - enjoying this splendid aircraft enormously (thanks also to JK Blom's brilliant liveries).

    Adam.
    XP11.50 | MSFS 2020
    Intel Core i7 2600K @ 3.40-4.69GHz | 8GB DDR3 | nVidia RTX2060 8GB | Win10 2004 64-bit 24Gb RAM



  12. #12

    Something wonky going on with landing

    This is a sweet plane, but it won't land. It appears that the wheels don't make contact with the runway during landing. They work properly during takeoff, but when you're landing, the wheels just "clip through" the pavement. The first time the aircraft notices that it has made contact with the ground, it is the metal struts and not the tires. This causes the plane to violently pitch forward / crash.

  13. #13
    Quote Originally Posted by SomeGuyinCO View Post
    This is a sweet plane, but it won't land. It appears that the wheels don't make contact with the runway during landing. They work properly during takeoff, but when you're landing, the wheels just "clip through" the pavement. The first time the aircraft notices that it has made contact with the ground, it is the metal struts and not the tires. This causes the plane to violently pitch forward / crash.
    Confirmed here. I could have sworn this wasn't a problem with the previous version (!).
    XP11.50 | MSFS 2020
    Intel Core i7 2600K @ 3.40-4.69GHz | 8GB DDR3 | nVidia RTX2060 8GB | Win10 2004 64-bit 24Gb RAM



  14. #14
    Quote Originally Posted by Adamski_NZ View Post
    Confirmed here. I could have sworn this wasn't a problem with the previous version (!).
    Hey these things happen. Asobo is continuing to make changes to how the sim (game) works, so I understand this is a moving target.

    Another little "gotcha" is the trim control. If you have your trim assigned to up 'n down buttons, I think it still works as expected, but if you have your trim assigned to a progressive control (rotary), then it's backwards from the way that Asobo has made it work for all of their default planes. So if that could be fixed too..that'd be great. (said in a very "office space" voice)

  15. #15
    Quote Originally Posted by SomeGuyinCO View Post
    Hey these things happen. Asobo is continuing to make changes to how the sim (game) works, so I understand this is a moving target.

    Another little "gotcha" is the trim control. If you have your trim assigned to up 'n down buttons, I think it still works as expected, but if you have your trim assigned to a progressive control (rotary), then it's backwards from the way that Asobo has made it work for all of their default planes. So if that could be fixed too..that'd be great. (said in a very "office space" voice)
    Heh - I hope my pervious post didn't come over as a whine!! Axis mapping is a disaster in MSFS. Eg. The AH Spitfire has about 3 axes mapped incorrecly (reversed).

    One thing I noticed was the the (in-sim) C of G was w-a-y forward - and could possibly account for the pitch-over. I moved it back a fair way ... even though it tended to float on flare, it still pitched over.

    Hopefully it's an easy thing to fix.
    XP11.50 | MSFS 2020
    Intel Core i7 2600K @ 3.40-4.69GHz | 8GB DDR3 | nVidia RTX2060 8GB | Win10 2004 64-bit 24Gb RAM



  16. #16
    Is the current version 1 or 1.1 (i.e. msfs_rapide_v1.zip or msfs_rapide_v1.1.zip)? I ask because the download link in the SOH library only takes me to the former, not the latter.

    Many thank in advance.

    Andy


    i7-8086K OC @ 5GHz, 64 Gb RAM, RTX 3090 FE
    Win10 Pro 64-bit, Reverb G2

  17. #17
    Quote Originally Posted by Airtrooper View Post
    Is the current version 1 or 1.1 (i.e. msfs_rapide_v1.zip or msfs_rapide_v1.1.zip)? I ask because the download link in the SOH library only takes me to the former, not the latter.
    It's 1.1 in disguise!!! If you download it and extract it, you'll see a 1.1 folder in there instead
    XP11.50 | MSFS 2020
    Intel Core i7 2600K @ 3.40-4.69GHz | 8GB DDR3 | nVidia RTX2060 8GB | Win10 2004 64-bit 24Gb RAM



  18. #18
    Quote Originally Posted by Adamski_NZ View Post
    It's 1.1 in disguise!!! If you download it and extract it, you'll see a 1.1 folder in there instead
    Many thanks indeed!


    i7-8086K OC @ 5GHz, 64 Gb RAM, RTX 3090 FE
    Win10 Pro 64-bit, Reverb G2

  19. #19

    Something wonky going on with landing





    SomeGuyinCO


    Members +Join DateOct 2021Posts2

    Hello Dave,

    The Dragon beiing one of my favourite msfs aircraft since fs2004, so first of all thank you really a lot for bringing back your beautiful contribution.

    But... all of a sudden, the last couple of days it won't land at all! And I'm not the only one with this problem as you can see in the added quote.

    Apparently it has nothing to do with update 1.1. or MSFS update 1.21.13.0 / Maybe with the latest Nvidia Driver Update: 497.29?

    Anyway, I sincerely hope there is a fix. There is no flightsimming day without the Dragon Experience.

    Thank you in advance and you and yours have a very Merry Christmas and Happy New Year.
    Gerald B


    Something wonky going on with landing


    This is a sweet plane, but it won't land. It appears that the wheels don't make contact with the runway during landing. They work properly during takeoff, but when you're landing, the wheels just "clip through" the pavement. The first time the aircraft notices that it has made contact with the ground, it is the metal struts and not the tires. This causes the plane to violently pitch forward / crash.



  20. #20
    No problems here(!!) ... have you got the latest version? I think I had that problem with an older model.
    XP11.50 | MSFS 2020
    Intel Core i7 2600K @ 3.40-4.69GHz | 8GB DDR3 | nVidia RTX2060 8GB | Win10 2004 64-bit 24Gb RAM



  21. #21

    Landing Problem

    Replaced version 1.1 by the old one 1.0 and the problem is solved: flying & landing perfect. (see message yesterday)

  22. #22

    I can't dowload this new update

    I love rhis plane. I have the first version. I can't download 1.1 update. ??? Best regards from the Alps in france

  23. #23

  24. #24

    Charlie McEwan

    Hello,
    Many Thanks -What a great free ware from Dave Gartree, can any one help me, found one click spot L/H Cockit fuselafe area below electrical gauges pax door opens with nice wooden step, cannot get freight door to open with another click spot found in same area, also can any one explain where I insert the word modern to get the radio in the VC I have added it to the line Title= before and after the " " but modern radio not appearing I am win 10 64 bit MSFS prem delux from M/S Store

    Any help muchappreciated
    Best Regards
    Charlie

  25. #25
    Thank you soo much for this beauty. I have to admit that I didn't like the desing at the beginning, it really looks like a dragonfly, but the more I use it the more I like it!! I share some captures enjoying it. Cheers
    PD: Its true, the cargo door button doesn't work.

    The livery is https://flightsim.to/file/22839/de-h...-ec-aay-iberia

    Click image for larger version. 

Name:	X de Havilland DH-89 Dragon Rapide.jpg 
Views:	25 
Size:	174.6 KB 
ID:	86607 Click image for larger version. 

Name:	de Havilland DH-89 Dragon Rapide (2).jpg 
Views:	19 
Size:	121.2 KB 
ID:	86608 Click image for larger version. 

Name:	de Havilland DH-89 Dragon Rapide (3).jpg 
Views:	24 
Size:	707.0 KB 
ID:	86609 Click image for larger version. 

Name:	de Havilland DH-89 Dragon Rapide (4).jpg 
Views:	19 
Size:	764.1 KB 
ID:	86610 Click image for larger version. 

Name:	de Havilland DH-89 Dragon Rapide (5).jpg 
Views:	25 
Size:	1,005.3 KB 
ID:	86611

Members who have read this thread: 127

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •