MAW - Green Water
Results 1 to 5 of 5

Thread: MAW - Green Water

  1. #1
    Members +
    Join Date
    Oct 2017
    Location
    United Kingdom of Great Britain and Northern Ireland
    Posts
    10

    MAW - Green Water


    Hi All,

    I'm using CFS3 with MAW, Ankhors Shaders and the New Environment MAW Package. When flying over water the textures appear green, rather than the expected blue (see attached screenshots taken off the coast of Malta).
    Does anyone know what the issue could be? Any suggestions greatly appreciated!

    Thanks in advance,
    Garbs
    Attached Thumbnails Attached Thumbnails Shot01-12-21-16-03-37.jpg   Shot01-12-21-16-03-31.jpg  

  2. #2
    Members +
    Join Date
    Oct 2017
    Location
    United Kingdom of Great Britain and Northern Ireland
    Posts
    10
    Here are 2 more screenshots which better depict the issue of green water. The water in the Mediterranean shouldn't be this colour!
    Attached Thumbnails Attached Thumbnails Shot01-12-21-19-09-25.jpg   Shot01-12-21-19-09-30.jpg  

  3. #3
    It looks like the opacity level is set too low.

    In the Shaders30 folder the seawater.fx file starts with a text section that looks like:

    #define BaseOpacity 0.99
    #define WaveBump 5.0
    #define WaveScale 5.0
    #define FoamAmount 0.32
    #define AddFoam

    Manually setting the Base Opacity to a somewhat lower value than this (0.50) will let you see the textures on the bottom of the sea rather than the color of the water animation textures.

    This is not something that gets accidentally changed, so perhaps something else is amiss with your set up.
    US Army, Major, Ret.

    Service To The Line,
    On The Line,
    On Time

    US Army Ordnance Corps.

  4. #4
    Members +
    Join Date
    Oct 2017
    Location
    United Kingdom of Great Britain and Northern Ireland
    Posts
    10
    Hi MajorMagee,

    When I took a look at my seawater.fx file the BaseOpacity was set to 0.99 already, and changing the value to anything else appeared to do nothing. After attempting that, I tried removing the shaders to see if they were the cause of the problem, only to find my water was still green (see attached screenshot). Any ideas as to what it could be?

    Thanks,
    Garbs
    Attached Thumbnails Attached Thumbnails Shot01-13-21-15-45-45.jpg  

  5. #5
    I tried a few things last night like changing the alpha layer in the cfs3h2o.dds file, and various water related settings in the ConfigOverrides.xml, and could not reproduce the effect. I know this has come up for some people in the past, but I don't recall what it took to resolve it.
    US Army, Major, Ret.

    Service To The Line,
    On The Line,
    On Time

    US Army Ordnance Corps.

Members who have read this thread: 49

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •