new material in model converter X - Page 2
Contribute Now
Goal amount for this year: 10000 USD, Received: 10,500.00 USD (105%)
Welcome Back, Unregistered     Today's Date:       Current Time: 

Please Support the SOH "2020 Charter Membership Drive"




Accepted Payment Types

Page 2 of 2 FirstFirst 12
Results 26 to 49 of 49

Thread: new material in model converter X

  1. #26
    Adjusting the Z bias worked great but it was on the ans_vc (without the $ sign) material.

    LouP

  2. #27
    Quote Originally Posted by D5turbi View Post
    Hi,
    It is not correct.
    If you just want to move an existing model part, use the "transformation" settings to move the model part in the desired direction, or even rotate it.

    You should only isolate, export or delete a model part if you want to replace it with another.

    Best
    Jean
    Interesting. I should not have said "the only way", since there usually seems to be any ways to do things.
    I have never done it via the transformation setting, since I have not seen any description on how to do it that way....so I do it the way I described instead. Fortunately for me, it has worked well.

    I'm always looking for better/easier ways to do things and since others are apparently not familiar with how to do this, would you mind describing the procedure for us?
    Current System Specs :
    FSXA & P3Dv4 | Windows 10 Professional for Workstations (x64)
    Motherboard: Gigabit Z390 Aorus Ultra, LGA 1151, Intel based
    CPU: Intel Core i9-9900K @ 3.60GHz | RAM: G.Skill Ripjaws V 16GB DDR4 3600
    GPU: ZOTAC GeForce GTX 980 Ti AMP! Extreme (6GB GDDR5)
    HD: 1TB SanDisk SSD Plus | PSU: KDM 750W ATX Power Supply

  3. #28
    No worries. I think you will never stop learning with this stuff, it's one of the things that makes it so much fun. I'll never get over the wealth of knowledge here at SO, it's awesome. So I have another brain pick. lol I am working on a couple of models that disapear in the sim when I add the additional props and I'm sure it's happened to some of you. Is there a fix for this or is the model beyond repair (as far as the props)?

    LouP

  4. #29
    awstub, just reading your post makes it sound easy. I'm trying to follow the CalClassics tutorial for a base FS9 to P3D conversion on a favorite Piglet helicopter model that some how missed conversion to FSX. I was unaware about using other programs besides Gmax. As you mentioned I am looking to add pilots, weapons, and some minor VC things. I'll experiment with your system and see how far I get.
    Fly Navy/Army (Ret. 2/2018)
    USN SAR
    DUSTOFF/ARMY PROPS

  5. #30
    Quote Originally Posted by Victory103 View Post
    awstub, just reading your post makes it sound easy. I'm trying to follow the CalClassics tutorial for a base FS9 to P3D conversion on a favorite Piglet helicopter model that some how missed conversion to FSX. I was unaware about using other programs besides Gmax. As you mentioned I am looking to add pilots, weapons, and some minor VC things. I'll experiment with your system and see how far I get.

    Well, "easy" means different things to different people. The method I use (i.e. with Blender) is easier for me, but others have methods that are easier for them...and probably more efficient too.

    Regarding Blender......I use version 2.79 rat the moment, because it works with the Blender2FSX add-on. With it, you can export directly from Blender to an FSX or P3D .mdl file.
    Once they make Blender2FSX that works with Blender v 2.82 I will switch to that.

    I consider myself to be mediocre at best. I am willing to help others though, since I know how difficult and frustrating it can be.
    Its super fun to convert something and get it to work though and once you get the hang of it you will want to do it even more.
    Current System Specs :
    FSXA & P3Dv4 | Windows 10 Professional for Workstations (x64)
    Motherboard: Gigabit Z390 Aorus Ultra, LGA 1151, Intel based
    CPU: Intel Core i9-9900K @ 3.60GHz | RAM: G.Skill Ripjaws V 16GB DDR4 3600
    GPU: ZOTAC GeForce GTX 980 Ti AMP! Extreme (6GB GDDR5)
    HD: 1TB SanDisk SSD Plus | PSU: KDM 750W ATX Power Supply

  6. #31
    I have only converted one prop airplane so far, and I'm sure it was by accident, but it not give me any problems.

    Quote Originally Posted by LouP View Post
    No worries. I think you will never stop learning with this stuff, it's one of the things that makes it so much fun. I'll never get over the wealth of knowledge here at SO, it's awesome. So I have another brain pick. lol I am working on a couple of models that disapear in the sim when I add the additional props and I'm sure it's happened to some of you. Is there a fix for this or is the model beyond repair (as far as the props)?

    LouP
    Current System Specs :
    FSXA & P3Dv4 | Windows 10 Professional for Workstations (x64)
    Motherboard: Gigabit Z390 Aorus Ultra, LGA 1151, Intel based
    CPU: Intel Core i9-9900K @ 3.60GHz | RAM: G.Skill Ripjaws V 16GB DDR4 3600
    GPU: ZOTAC GeForce GTX 980 Ti AMP! Extreme (6GB GDDR5)
    HD: 1TB SanDisk SSD Plus | PSU: KDM 750W ATX Power Supply

  7. #32
    Quote Originally Posted by awstub View Post
    Regarding Blender......I use version 2.79 rat the moment, because it works with the Blender2FSX add-on. With it, you can export directly from Blender to an FSX or P3D .mdl file.
    Once they make Blender2FSX that works with Blender v 2.82 I will switch to that.
    There is a version that works with 2.82. Have a look here.
    https://www.fsdeveloper.com/forum/th...3d-fsx.447054/

  8. #33
    Quote Originally Posted by LouP View Post
    No worries. I think you will never stop learning with this stuff, it's one of the things that makes it so much fun. I'll never get over the wealth of knowledge here at SO, it's awesome. So I have another brain pick. lol I am working on a couple of models that disapear in the sim when I add the additional props and I'm sure it's happened to some of you. Is there a fix for this or is the model beyond repair (as far as the props)?

    LouP
    I've never had models disappear in the sim, but I did have a problem with the occasional merged part not being visible.
    That turned out to be a LOD issue. The merged part, from a different model, had it's LOD set at a different value to the model it was being merged with. Could be worth checking that.

  9. #34
    Here a copy of an email sent to a friend for the use of the "transformation" tool in MCX.

    The texts are in French. Their translation:

    Image 1
    right click on #transformation then left click on transformation

    Image 2:
    right click on transformation then left click on Edit transformation

    Image 3:
    Modify the parameters X Y and Z, they are in meters, then click on OK.

    It is also possible to rotate the modelpart or change its size.





    Attached Thumbnails Attached Thumbnails balise2.jpg   balise3.jpg   balise1.jpg  

  10. #35
    Wow, very good to hear. Thanks Dave

    Quote Originally Posted by DaveWG View Post
    There is a version that works with 2.82. Have a look here.
    https://www.fsdeveloper.com/forum/th...3d-fsx.447054/
    Current System Specs :
    FSXA & P3Dv4 | Windows 10 Professional for Workstations (x64)
    Motherboard: Gigabit Z390 Aorus Ultra, LGA 1151, Intel based
    CPU: Intel Core i9-9900K @ 3.60GHz | RAM: G.Skill Ripjaws V 16GB DDR4 3600
    GPU: ZOTAC GeForce GTX 980 Ti AMP! Extreme (6GB GDDR5)
    HD: 1TB SanDisk SSD Plus | PSU: KDM 750W ATX Power Supply

  11. #36
    Great stuff, D5turbi. Thanks!


    Quote Originally Posted by D5turbi View Post
    Here a copy of an email sent to a friend for the use of the "transformation" tool in MCX.

    The texts are in French. Their translation:

    Image 1
    right click on #transformation then left click on transformation

    Image 2:
    right click on transformation then left click on Edit transformation

    Image 3:
    Modify the parameters X Y and Z, they are in meters, then click on OK.

    It is also possible to rotate the modelpart or change its size.





    Current System Specs :
    FSXA & P3Dv4 | Windows 10 Professional for Workstations (x64)
    Motherboard: Gigabit Z390 Aorus Ultra, LGA 1151, Intel based
    CPU: Intel Core i9-9900K @ 3.60GHz | RAM: G.Skill Ripjaws V 16GB DDR4 3600
    GPU: ZOTAC GeForce GTX 980 Ti AMP! Extreme (6GB GDDR5)
    HD: 1TB SanDisk SSD Plus | PSU: KDM 750W ATX Power Supply

  12. #37
    Delighted to have been able to help.
    For my part, it is the "still", "slow" and "blurred" propellers that cause me insoluble problems although I followed the tutorial from calclassic to the letter.

  13. #38
    Quote Originally Posted by D5turbi View Post
    Delighted to have been able to help.
    For my part, it is the "still", "slow" and "blurred" propellers that cause me insoluble problems although I followed the tutorial from calclassic to the letter.
    Yep, sometimes they just don't work. I've seemed to have trouble when the props are created with multiple parts and the animation is defined in different levels of the "tree" that make up the prop. It's gotten to the point where I know which ones are going to work and which ones won't before I even test them. I'm right there with you

    LouP

  14. #39
    OK, the model in question combines everything you report:

    counter-rotating propellers, with variable pitch, made up of multiple parts.

    So I drop for this plane which seems impossible to convert in full for P3D.

    Too bad, it's a beautiful bird (Tupolev Tu-114)

  15. #40
    I'm sure there is a way, I just haven't been able to find it yet. I am more and more impressed all the time with McX.

    LouP

  16. #41
    Hi Again, So I am not alone and this is not just driving me nuts so I did a lot of reading and playing around and for the life of me can not get the props visibility to behave properly. The aircraft has a complex tree regarding the props and I read that you should only set the visibility conditions on a model part even though the animation may be defined at a higher level. What urks me is while I was playing around I got one of the props to work but as soon as I moved on and tried to fix another prop, the one I got working broke and the blades were always visible once again. Even though I was careful not to adjust the one that I got working. I am convinced that this can be done, I just can't see any logic in it right now. Any suggestions or guidance would be appreciated by me and others following this thread.

    Thank you,
    LouP

  17. #42
    Charter Member 2016
    Join Date
    Jun 2005
    Location
    Back in the land of maple syrup
    Age
    58
    Posts
    517
    The Anson model is very odd to convert, as LouP has noted the props don't seem to recognize the visibility conditions.

    I have converted several prop models and never had an issue until now. As an example Vladimir Zhyhulskiy's An-2 series of models convert nicely and their props behave correctly and respect the visibility tag.

    Needs more investigation

    Gavin

  18. #43
    Charter Member 2016
    Join Date
    Jun 2005
    Location
    Back in the land of maple syrup
    Age
    58
    Posts
    517
    I did a bit more testing and it gets weirder and weirder.

    None of the visibility conditions are working with this model. I assigned the blurred prop the landing lights visibility and when I turn the landing lights on the prop blips into visibility very briefly and then disappears again.

    Tried attaching a light to the model and assigned it the landing light visibility. Get the same result, turn the lights on and the light appears for a second and then disappears again.

    Will post this over at FSDeveloper and see if Arno has any ideas.

    Gavin

  19. #44
    Hate to point this out but it's not exclusive to the anson so fixing this will fix many many other addons. I've even tried to assign silly conditons that cretainly should make things "disapear" but no, they remain. I am convinced that it is dependent on where objects are placed in the model tree but not sure how yet. I've dragged object to another part of the tree and the visibility conditions seem to start taking hold On the plus side, I'm getting good with the transformations. Thank you for the explanations, I'm sure others are benefiting, also.

    LouP

  20. #45
    Charter Member 2016
    Join Date
    Jun 2005
    Location
    Back in the land of maple syrup
    Age
    58
    Posts
    517
    I have been having a conversation with DaveWG over at FSDeveloper and he has told me what is going on with the props.

    Seems the issue with prop visibility has to do with the Rotation entry in the Propeller section of the aircraft.cfg
    the rotation parameters are negative numbers in the aircraft.cfg and this is what messes up the visibility (I have no idea why).

    If you change
    rotation = -1, -1
    to
    rotation = 1, 1

    then the visibility conditions start to work correctly.

    We also identified an issue with the xml code in the landing light switch on the Anson that stops the landing lights from working correctly in P3D.
    Dave very kindly (and quickly) sorted out the code and posted an updated gauge file
    https://daveg.cbfsim.org/files/Anson_Mk1.zip

    thanks to Dave for sorting all this out.

    Gavin

  21. #46
    Awesome awesome awesome. Thank you, Gavin.

    LouP

  22. #47
    Very interesting.
    I looked at the aircraft.cfg of Tupolev which has the same problem of visibility of the propellers and I realized that there is no section [propeller] in this file.
    It will not be easy to create this section for the 8 propellers of the machine ...

  23. #48
    Quote Originally Posted by D5turbi View Post
    Very interesting.
    I looked at the aircraft.cfg of Tupolev which has the same problem of visibility of the propellers and I realized that there is no section [propeller] in this file.
    It will not be easy to create this section for the 8 propellers of the machine ...
    P3d only supports 4 engines / propellers anyway, so the other 4 are simply reusing the same animations. You could try copying the appropriate sections from the default AI TU-95. Worked for me.


  24. #49
    Thank you DaveWG
    I will try to do it.

    Edit :

    Unfortunately it does not work. The new propellers of the TU 95 remain "still" and are visible, engines running
    Last edited by D5turbi; April 13th, 2020 at 07:45.

Members who have read this thread: 158

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •