Controller Hardware Anomaly
Results 1 to 4 of 4

Thread: Controller Hardware Anomaly

  1. #1

    Controller Hardware Anomaly

    Just wanted to ask here (repost from the P3D forum),

    This morning I went to run a test of one of my models after making a tweak and after I started P3D and went to fly, I noticed that all of the buttons on my X56 stick were not functioning. The Axis were all fine. I did the normal troubleshoot to see what was going on, no joy. I closed P3D and went to DCS, same thing. Oddly my X56 throttle's buttons and sliders worked normally. This X56 unit (which was a replacement for my original) doesn't have a lot of time and wear on it and has already outlasted the original I had by 3 years. I was able to figure out that the buttons on the stick were actually fully functional but not communicating with either sim. I did a Hail Mary pass/move and decided to uninstall the drivers and reinstall them. Boom! Problem fixed. That leads me to the question if this was some odd glitch or overwrite with a Windows 10 update involving USB drivers/firmware that screwed things up? Anyone else seen this sort of thing? I also take note that it looks like the X56 drivers haven't been updated in over 2 years which makes me wonder if they may be prone to glitches like this with each Windows update or other issues.

    [SIGPIC][/SIGPIC]

  2. #2
    Members +
    Join Date
    Jun 2018
    Location
    HB, Ca.-Seattle,Wa.-Fujieda-Shizuoka-Japan
    Posts
    11
    At times both my axes for the stick will vanish. I have to go into the software (X56 HOTAS) and re calibrate both then I'm back in business. I have heard that it's best to use a powered USB hub and plug both controllers into it. Which I do.
    Windows 10 Pro 64bit 1909 Build 18363.836
    Gigabyte GA-Z68XP-UD3 (BIOS F-10)
    Core i7 3770K
    G-Skill Trident X 32GB DDR3 CL7-8-8-24
    Asus RX 570 OC Edition 4GB DDR5 Crimson 20.4.2
    1TB Crucial MX500 SSD
    1TB RAW Mushkin SSD
    1TB RAW Mushkin SSD
    1TB RAW Mushkin SSD
    LG Blue Ray Burner DL
    Rosewill mid tower Challenger
    Antec 650w PSU
    X56 HOTAS
    TrackIR 5 Pro

  3. #3
    Quote Originally Posted by udidwht View Post
    At times both my axes for the stick will vanish. I have to go into the software (X56 HOTAS) and re calibrate both then I'm back in business. I have heard that it's best to use a powered USB hub and plug both controllers into it. Which I do.
    Yeah, I figured out that using the calibrate function would usually fix the issue although I ended up seeing the POV hat stop working and the re-calibrate didn't fix that. Apparently just a bad contact with the pins between the stick and the base which I fixed by unscrewing the stick, pushing on the contact pins a few times, cleared right up. So far, the X-56 has held up a lot better than the X-55 did. I will take your advice on the powered USB port.

    [SIGPIC][/SIGPIC]

  4. #4
    I always get some strange behaviour with my HOTAS Warthog and Saitek pro combat rudder pedals, but only in DCS World. Every now and then I need to redo my controls, usually after an update to DCS, although I will just fix up each aircraft as I fly it. Also, the first time I set controls for an aircraft, a lot of functions are pre mapped, but I always find that axis controls are triple mapped to joystick, throttle, and rudder. This plays havoc obviously, until I fix it up by deleting the extra maps. Sometimes buttons and key maps are also duplicated across two or more devices.
    "Try to stay in the middle of the air. Do not go near the edges of it. The edges of the air can be recognized by the appearance of ground, buildings, sea, trees and interstellar space. It is much more difficult to fly there".

Members who have read this thread: 3

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •