UPLOADED: Spitfire Mk.II Package - Page 4
Page 4 of 5 FirstFirst 12345 LastLast
Results 76 to 100 of 110

Thread: UPLOADED: Spitfire Mk.II Package

  1. #76
    I can't get the head tilt to work, the other TIR functions are the same as always. Tried to figure out what Major Magee did but I had no success. I need a little more detail of the steps required please. This may be tied to the the problem below.

    The only clickable functions I have are what the other cockpits showed animated, except the normal-lean mixture control doesn't work, it still works with the keyboard. The new controls show the symbols when I hover over them but don't do anything. They don't work with the keyboard either. I did the key binding.

    Also the real systems module doesn't shut down when I shut down CFS3.

    This is a Win7 system.

  2. #77
    I'm on Win 10 so it may be different in Win 7.

    I run TrackIR5 in Admin mode.

    In the profile you're using for CFS3 make sure the Motion Adjustment check box for roll is selected.

    Choose the Roll Axis and create a response profile similar to the ones you have for the pitch and yaw Axis (low in the center and more toward the edges).
    US Army, Major, Ret.

    Service To The Line,
    On The Line,
    On Time

    US Army Ordnance Corps.

  3. #78
    Join Date
    Sep 2007
    St. Petersburg, FL
    Thanks for the replies about the FSX model. I'll try the A2A version. Happy Holidays to all.

  4. #79
    I run TrackIR5 in Admin mode also. I made sure roll axis was on and adjusted the curve some but still doesn't have tilt. It does tilt in the TIR setup screen, always did.
    I think it's all the same problem, head tilt, lack of new controls and guns not firing, since I can't take the gun safety off.

    I started ETO the old way, not through the module and it does the same things. I thought to get the module features to work at all you had to start through the module shortcut.

    Does anyone have this working correctly in Win 7?

  5. #80
    The symptoms you describe make it seem like the Real Systems Module isn't running at all. Try starting the Real Systems Module (make sure trackIR is running FIRST) and then after the module has loaded CFS3, start a flight in one of the new Spitfires. Once you are in the mission, pause and minimize CFS3. Press CTRL+ALT+DELETE and bring up the task manager. Click on the Processes tab, and look for the following processes to appear in the list:
    CFS3 Real Systems Module.exe
    SpitMkIIB_main.exe (this one depends on which variant you selected, might be SpitMkIIA_main.exe or SpitMkIIB_late_main.exe, etc)

    There could be some other similar named processes up too, depending on what is going on at the time. Let me know if any of these aren't showing up and it will help me figure out what the issue is.

  6. #81
    I had just done that today, and the only ones running were:
    CFS3 Real Systems Module.exe*32
    Systems HotKey.exe
    Systems Main.exe
    Systems TIR.exe
    I manually ran Systems Launch.exe tried to run Systems Switch.exe but that stopped all except the Systems Main.exe.

    None of it changed anything.

    I then stopped all of them in task manager and it still acted exactly the same. I could still click on the "old animated cockpit controls and see the symbols at the new features.

    I also added Run as Administrator to all these .exe files files but it didn't change anything.I have not seen any of the SpitMkII executes, didn't know they exisited.

    All four are still running after I shut down CFS3.

    Glad your back, I had no idea what to try next.

  7. #82
    The next time you shut down CFS3, check to see if the cfs3.exe process is still running in the background. I use windows 7 as well, and at some point an update messed up how CFS3 shuts down and left the process still running in the background if you clicked through the menus to exit. Instead, I use the Exit Immediately command (default keys are CTRL+SHIFT+Q I think) and this allows CFS3 to shut down fully. Once you have confirmed that cfs3.exe is no longer running in the background, try running the module again.

    If that doesn't work, one of two things could be the issue.

    1. Did you edit any xdp files of the aircraft included in the package? If you changed the ShortName value, the Module won't recognize them.

    2. Perhaps you are missing some files in the systems folder? It should look like the screenshot here:
    Attached Thumbnails Attached Thumbnails folder.jpg  

  8. #83
    I have ETO using cfs3win7.exe and it is not still running in the processes background after I shut down using CTRL+SHIFT+Q. The Real Systems Module, Hotkey, Main, and Tir are still running in processes. In the applications task manager window shows, Real systems Module and CFS3 ETO Expansion are still running. If I stop the Systems Module from the icon on the task bar the real systems Module application shuts down but the processes do not and CFS3 ETO Expansion application is stilll running. Just the CFS3 ETO Expansion application does't stop it from starting up again. Hope you can follow all this.

    I have not edited any of the new spitMkII aircraft files.

    My systems folder looks exactly like yours. The SpitMkII folder, in the systems folder, has 274 files and 193,919,826 bytes.

    I have tried more than one SpitMkII.

  9. #84
    Ok, most and possibly all of your problems are due to the fact that your cfs3 exe is named cfs3win7.exe. Why is yours named differently? In my ETO install it is named cfs3.exe. Was there an update that changed it somewhere that I missed, or did you make the change yourself? The Real Systems Module looks for cfs3.exe, and will not work if you have it named differently.

  10. #85
    It is called "Windows 7 Install Fix" in the Projected Knowledge Base dated Sept 11 2010.

    I will try to put it back to cfs3.exe.

  11. #86
    It appears everything is working now, didn't actually take off yet but did start it with the cockpit controls. The TIR tilts now as well.

    Looks like I don't need the crs3win7.exe anymore. It was probably just the run as administrator and run in XP sp3 mode that I needed.

    Thanks for your help.

  12. #87
    Absolutely! Glad you're up and running now. Didn't know about that Windows 7 Install Fix, sounds as though it is no longer needed?

  13. #88
    I can't get the guns or gunsight to work. Everything else I've tried seems to work correctly. I can take the safety off with the switch or keyboard. Do you have to be airborne to fire the guns? The gunsight controls move but it never lights up or moves. The static sight is there.

    There is a lot going on when you fly these aircraft. I can see I will have to practice a lot. A surprise with the wounded pilot limping away after a slow speed crash landing. Nice to see a different animation.

  14. #89
    The Spitfire Mk.IIA uses the cannon button to fire the guns. This is to get around a cfs3 issue with effects.

    The Spitfire Mk.IIB uses the normal gun button for the guns and the cannon button for cannons. The cannons will not fire with the undercarriage down, as mentioned in the pilot's notes. The guns still fire with the undercarriage down.

    All guns can freeze at high altitude if you don't keep the radiator temperature high enough. The radiator has a gun heating position which will melt any ice that accumulates on the guns. Guns can also jam randomly.

    If none of those things explain your problem, I recommend making sure you installed all the gun and weapon files, added the lines to the effects xml, and sounds xml.

    It sounds like you didn't add the lines to the TextureMagic.ini to activate the gunsight. Also make sure you have all of the effects dds files installed from the download.

    Glad everything else seems to be working, and yes, there is a lot more to do to fly this one! The animations for the pilot must be part of something else you've installed, we didn't change those.

  15. #90
    I figured out that the guns do fire by shooting into the water. I could see the splashes, but there is no sound and that's why I did't think they were working. I found the sound file for that gun and the wav file works. What do I look for now?

    I haven't checked for the gunsight files yet.

  16. #91
    Ah yes, looks you just didn't install everything. Also make sure you have muzzle flashes, which need the lines added to the effects.xml and the dds files installed per the instructions in the download.

    Also, forgot to reiterate, though it is in the readme as well, most aircraft do not have tracers. This is correct, since the RAF was rarely, if ever, using tracers at this stage of the war.

  17. #92
    It looks to me like all the files are there.

    I did not add all the reticle files to the TextureMagic.ini from the Spit mkII install as they were already there from the 2019 shaders install. Should I have overwritten them?

    I did check, and the gunsight.exe process is running after I start a flight, just doesn't do anything.

    No muzzle flashes either as well as no gun sound.

  18. #93
    It sounds like you didn't add the lines from "ADD TO effects.xml.txt" and "ADD TO sounds.xml.txt" to the effects.xml and sounds.xml, respectively.

  19. #94
    I checked/added those files as well.

  20. #95
    Added the txt files themselves or opened them, and copied and pasted the text into the effects.xml and sounds.xml per the instructions?

  21. #96
    The TextureMagic.ini that I left from the shaders install has an empty line between each set of three styles of reticles, but I noticed that the ones in spit mkII download does not have these spaces. Could this be causing the sight problem?

    Did add the text files, effects and sounds

    I seem to get all the cockpit sounds but not sure about all the external sounds like tire chirp belly landing etc. Will have to check further. I definitely get a lot of noise when I over heat the engine and it blows/seizes up, which is easy to do and quick. Have to fly with one eye on the temperature.

    Will have to take another long hard look at all the installation files. Maybe I left out a < or > or some other small detail, or put whole section in the wrong folder/file.

  22. #97
    Everything seems to point to not having correctly edited the effects.xml and sounds.xml. Here are the relevant sections from the instructions:


    Editing the main game effects.xml file for new effects to work. You need to add new lines of text to the bottom of your effects file. Make a back up copy of your game's effects file.

    open the effects file (with notepad) and scroll to the bottom of the effects file. the last entry you see is: </Effects>

    Now open the supplied file called: "ADD TO effects.xml.txt"

    You need to copy the supplied text (everything including the title <START_GECKO_SPITFIRE_IIB_EFFECTS_MARCH_31_2019/>) and put it above the last line that says </Effects>

    Now save and close the effects file. REMEMBER make a back up of your effects file before you do this step in case you stuff it up.......



    Follow the instructions in the "ADD TO sounds.xml.txt" to edit your sounds.xml.

    So if for example perhaps you copied and pasted the lines to the bottom of the effects.xml, but didn't make sure the new lines were added ABOVE the final </Effects> tag at the bottom of the file, then the new effects won't be recognized.

  23. #98
    And yes - watch that temperature like a hawk! If you see it getting excessive, you need to put the nose down to speed up (more airflow through the radiator), open the radiator (also more airflow through the radiator), or reduce power (less heat) or some combination of the three or things will get very noisy and then very quiet! Takes some getting used to since we never had to deal with that before in CFS3.

  24. #99
    I down loaded the spit mkII again and add them to BoB. All seems to be working, including gun sounds and muzzle flashes. Also the gun sight works as it should.

    I then used the new downloaded files and folders from BoB and reloaded these in ETO. Same problems I had before. I may reinstall the backup ETO and reload the spit mkII again.

  25. #100
    Before doing a full reinstall, try comparing the sounds.xml and effects.xml from your working install with the ones in the install that are not working. I'm 99% sure your problem is in those two files.

Members who have read this thread: 1


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts