Square cannon tracers
Results 1 to 9 of 9

Thread: Square cannon tracers

  1. #1

    Square cannon tracers

    All the aircraft in ETO using the "avhistory_gb_gun_hispano_mk2" have the square tracers.

    The aircraft with "20mmMkIIHispano_gun" are ok.

    The only effects I've change recently were for the wing tip vapor trails. Could this be the problem?

    Here is what i did:RENAME tr_condenstrail_basis2.dds to tr_condenstrail_basis3.dds in the effects/Fxtetextures folder Keep tr_condenstrail_basis2.dds also.

    Then add this into the [HighAltSprite] section of the shaders30/texturemagic.ini:
    tr_condenstrail_basis3.dds= 2500|-1500

    Then replace this into the effects.xml file:
    <fx_N_gtrail ClassName="GroupEffect" Effect0="N_track_contrail_s"/>
    <N_track_contrail_s ClassName="TrackEffect" FlatTrack="0" Lifetime="0" InitialDelay="0" ParticleLifetime="0.15" FadeInTime="0.02" FadeOutTime="0.12" PosX="0" PosY="0" PosZ="0" CountSegments="5"
    SegmentLength="2" Width="0.25" WidthGrow="1.2" InitialAlpha="0.00" InitialColor="250 250 255" Alpha="0.55" Color="250 250 255" FinalAlpha="0.00" FinalColor="250 250 255" BlendMode="QuadSprite"
    Texture="tr_condenstrail_basis3.dds" ZBias=".03"/>

    I found some old threads about square cannon tracers but all that did was confuse me.

    Any advise would be appreciated.

  2. #2
    Senior Member sixstrings5859's Avatar
    Join Date
    May 2011
    Location
    Sulphur,South West Louisiana in the good'ol USA
    Age
    54
    Posts
    2,370
    If i remember correctly it has to do with maybe the new Spitfires or FW-190A's than anything else. Did you recently install them ? If you did please read the readme's included with the aircraft files and you should find your answer there. That is what happened to me.I have bad memory problems due to brain problems but i think that is what i did. Maybe someone more helpful will come along to help. Regards,Scott

  3. #3
    This problem keeps cropping up as files get copied and modified.

    http://www.sim-outhouse.com/sohforum...=1#post1168168
    US Army, Major, Ret.

    Service To The Line,
    On The Line,
    On Time

    US Army Ordnance Corps.

  4. #4
    To MajorMagee

    Per your link to the other thread, are you suggesting that I try installing the all in one effects package? I downloaded it a while back.

  5. #5
    I have never added any aircraft.

    I did install the all in one effects package but it didn't resolve the square tracer problem.

    I found the following files for the round.

    AvHistory_gb_round_hispano_mk2.xpd

    <?xml version="1.0"?>
    <UnitData>
    <General Allegience="" LongName="" ShortName="" ModelName="" BlastDamageScale="1.0" ImpactDamageScale="1.0" FireDamageScale="1.0" Priority="2" Type="weapon" EnteredService="01/01/1944" BlastDamageMod="0" ImpactDamageMod="0" FireDamageMod="0" AllowSpawn="n" Category="weapon" Country="Britain" Mass=".39395"/>
    <Description String=""/>
    <Weapon WeaponType="shell" ImpactDice="1" ImpactDieSize="1" ImpactOffset="65.39" BlastDice="1" BlastDieSize="1" BlastOffset="63.19" BlastRadius="1.3" FireDice="1" FireDieSize="1" FireOffset="11.6" ExplodeEffect="fx_grndexpl_t" GroundEffect="fx_bltgnd_m" AirEffect="fx_bltpln_m" WaterEffect="fx_bltwtr_m" TracerEffect="tracer_yellow_smoke20"/>
    <Loadouts/>
    <GunStations/>
    <DamageBoxes/>
    <Systems/>
    </UnitData>


    effects.xml
    <fx_tracer_yellow_smoke20 ClassName="GroupEffect" Effect0="tracer_yellow_smoke20" />

    <tracer_yellow_smoke20 ClassName="TracerEffect" TracerLength="2.0" TracerWidth="2.0" TracerRorationSpeed="500" TracerBlendMode="Add" TracerSideTexture="tracerside5yellow.dds" TracerEndTexture="tracerend5yellow.dds" SmokeLength="1600" SmokeWidth=".9" SmokeRorationSpeed="1200" SmokeBlendMode="QuadSprite" SmokeSideTexture="tracerSmoke4.dds" SmokeEndTexture="black.DDS"/>

    I tried all the combinations of "Add" and "QuadSprite". None of them made any difference. I do have all the exact dds files called for as well as several other variations.

    At this point I have no idea how to fix this problem. Maybe I need to change to a different weapon.

    Anybody have any ideas I could try?

  6. #6
    I gave up trying to fix the tracers for the avhistory_gb_gun_hispano_mk2 and switched to the 20mmMkIIHispano_gun. Seems to be working like it should, tracers and all, even though I never could find the tracer effects for it. I didn't change any other parameters.

  7. #7
    Senior Member sixstrings5859's Avatar
    Join Date
    May 2011
    Location
    Sulphur,South West Louisiana in the good'ol USA
    Age
    54
    Posts
    2,370
    Think there might have been a texture problem with the tracer effect. I had to delete a few texture files to get mine to work but that was with a couple of new aircraft i installed.Can't remember what textures i had to delete but it got everything working again correctly. I think there is a link to discussion about it in the stickies,(knowledge base), section.This may not be related to your problem as you said that you have not installed any new aircraft. Regards,Scott

  8. #8
    sixstrings5859 I found the link and tried it but it didn't work for me.

  9. #9
    Senior Member sixstrings5859's Avatar
    Join Date
    May 2011
    Location
    Sulphur,South West Louisiana in the good'ol USA
    Age
    54
    Posts
    2,370
    Did you modify the mentioned fx texture files,or do you even have them.? It was simple and did the trick for me. Maybe it could be related to the mods you did but i don't see how that could effect the tracer effects.

Members who have read this thread: 57

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •