FSX Steam Crashes When Switching To Windowed Mode (Solution)
Contribute Now
Goal amount for this year: 10000 USD, Received: 10,460.00 USD (105%)
Welcome Back, Unregistered     Today's Date:       Current Time: 

Please Support the SOH "2020 Charter Membership Drive"




Accepted Payment Types

Results 1 to 4 of 4

Thread: FSX Steam Crashes When Switching To Windowed Mode (Solution)

  1. #1

    FSX Steam Crashes When Switching To Windowed Mode (Solution)

    I recently had to reinstall everything after having a hard drive die so I decided to install the Steam version of FSX. At first glance everything went off without a hitch, I installed the Orbx Sceneries, REX, FSUIPC, ACCUSIM and a ton of aircraft. After getting it all set up I installed Plan G and went for my first flight but found that when I switched to Windowed mode the program would crash. I looked hard for a solution, went to the Steam Forums and found I wasn't the only one but there was no solution. So, after about a week of tweaking and tinkering I started uninstalling programs but I still had the CTD every time I went to windowed mode.

    So, yesterday I installed FSX Steam on a different PC that I have and low and behold no CTD's when running the fresh install. So, today I decided to reinstall the program on my main PC and guess what it worked fine with no products installed and I was able to jump in and out of Windowed mode without any issues. So, as I am adjusting the settings I set the water detail to high and bam I get a CTD in windowed mode when I go back out to the game. So, I try this on the other PC and same thing.. Set the water back down to low 2, I think, and everything works fine. I am wondering if this isn't a directx, windows 10 thing?? But, that was my solution and everything is working okay. I spent the rest of the day getting my ORBX stuff installed and I am happy to report its all working like it should.

    If memory serves, wasn't their a bug like this when the original FSX came out?

    I hope this helps and I was going to post this over on Steam but I didn't have a forum profile setup at the moment.
    Intel I7 8700 16gb DDR4 RAM GTX 1060 3GB with Windows 10

  2. #2
    Senior Administrator Roger's Avatar
    Join Date
    Oct 2000
    Location
    EGCD...they bulldozed it!
    Age
    68
    Posts
    9,735
    Have you tried updating your video card drivers?
    SYSTEM :
    OS:Win7 Home Premium 64 bit UAC OFF!
    DX version Dx10 with Steve's Fixer.
    Processor:I5 4670k overclocked to 4.4 gHz with Corsair CW-9060008-WW hydro cooler
    Motherboard:Z87
    RAM:16 gig 1866 gigaHz Corsair ram
    Video Card:MSI 1070 8 gig ram
    HD:2Tb Samsung 850 evo SSD

    To err is human; to forgive is divine

  3. #3
    The solution for me was to turn the water detail down, sorry I wasn't clear there but thanks for the reply. Wanted to just put this out there in case anyone else had this issue.
    Intel I7 8700 16gb DDR4 RAM GTX 1060 3GB with Windows 10

  4. #4
    So, I went out on a limb and tried installing REX again, but get the same crash when switching from full screen to windowed mode no matter what the water texture is set at. I removed REX and set the water back down to low 2 and everything works just fine. I sent a request to REX to be added to their support forums so I can look there. Ideas? This only occurs when increasing the water texture setting above low 2.
    Intel I7 8700 16gb DDR4 RAM GTX 1060 3GB with Windows 10

Members who have read this thread: 0

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •