I tried installing the v.2 upgrade this morning myself. Seems to be something wrong with line 51 off the configdatabase file. I removed the new one and replaced it with one from an old install I have...