PDA

View Full Version : Solution for low framerate(FPS), Lag spikes under Windows 7



trucker17
September 1st, 2014, 13:50
This was posted by Daniel Cziranku on another site.
After trying it out, I found it worked fantastic, and want to share it here.
Here is what he posted.
--------------------------------------------------------------------------------------------------------------------------------------------------------------------
If you use Windows 7, and you have a strong machine but still have some LAG, low FPS or unstable performance, here's a little trick you can try:
You'll have to turn off Multimedia Class Scheduler in both msconfig, and modify a key in the registry. This module causes fps drop-down, lag, and many more terrible things to our gaming performace. I turn this off on every build of Windows 7, every install.
so, let's get started

STEP #1
1. click on windows key / start menu
2. in the search field type and run: msconfig
3. click on the services tab, and search "multimedia class scheduler". uncheck the checkbox
4. if unchecked, click ok. when asked, DON'T restart your system. do STEP #2 before restarting !
( also, you can go through the "startup" tab's list, If you have something that isn't necessary to start with windows bootup, you can take them out easily here. this can save boot time and memory, too )

STEP #2
1. click on windows key / start menu
2. in the search field type and run: regedit
3. on the left side open the following path: HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > services > AudioSrv
4. click on AudioSrv, and on the right side of the window there will be a list, search and doubleclick "DependOnService"
5. after you opened the little window, DELETE the "MMCSS" part. only that part, leave the other 2 alone.
6. if you deleted it, click OK and restart your computer.

ACHTUNG ! you need to go through both step 1 and step 2 in order to fully disable this little imp !
I gladly help anyone who needs it, just drop some letters and I'll reply.

Hope it helps a lot of you, have a nice day !

_486_Col_Wolf
September 1st, 2014, 14:11
Trucker,

Will this work for CFS2 as well?

trucker17
September 1st, 2014, 14:32
I am not sure if it will......But I take it should, as it deals with the lag and stutter in the computer....
Give it a try, and let us know.....Record what you change, incase it does not help, you will be able to change it back.....

I know with my system it helped a lot, I have even been able to adjust my settings higher, and still have a smooth system.....
On another note.....

I have also noticed that the LOOP in the sounds are less noticeable......

Bradburger
September 1st, 2014, 19:51
Thanks for reposting this tip trucker17.

I found the original post by Daniel Cziranku, and it would seem it's not FSX specific, but has helped other sims/games too!

I tried it on my vintage Asrock Dual 939 Sata2 system (Athlon X2 4400 oc'd, 3GB RAM, Radeon 4850 HD, SB Audigy Platinum), and it seemed to make a big improvement over what I had before.

No more spikes, stutters, or large fps drops, which I was experiencing before in FSX. (Acceleration in DX10 preview, w/DX10 Scenery Fixer).

I took up the RealAir Spitfire over the older Godzone Wanaka scenery, and for the first time, the flight was smooth and good. Even TrackIR seemed smoother!

I did notice though that the sound would break up and 'crackle' for a bit when switching views, but this seemed to die down after a while.

I think it might also have helped the times when FSX sound engine gets 'confused', and plays the wrong engine samples after changing views.

Cheers

Paul

manfredc3
September 1st, 2014, 20:33
Thanks for posting that tip here.

Even though I have no fps issues running FSX under Windows 7, with thanks to the well known tips from Boyote and Kosta, I will certainly give it a try. I can always reverse the modifications (I always make copies of files before altering them!)

olderndirt
September 4th, 2014, 19:38
Sounded good to me - first thing I noticed was no Audio service. Tried restoring the changes but still no audio. This been a problem for anyone else?

trucker17
September 4th, 2014, 21:42
I have not had any problems with it.

DaveWG
September 4th, 2014, 23:08
No problems here, but no noticable improvement either.

Paul J
September 12th, 2014, 17:25
Interesting, but for what it's worth - why not just open Windows Services and disable it through it's properties? It's normally set to "Automatic", but Windows stops it running anyway, when it's not needed by any Multi-Media apps, so I have no idea why removing it should make any difference to fsx.

pj

Paul J
September 13th, 2014, 09:47
Interesting, but for what it's worth - why not just open Windows Services and disable it through it's properties? It's normally set to "Automatic", but Windows stops it running anyway, when it's not needed by any Multi-Media apps, so I have no idea why removing it should make any difference to fsx.

pj

...and further following up - removing the MultiMediaClass scheduler will prevent Windows Audio from starting because the W.Audio depends upon the MMCS (https://www.dropbox.com/s/hpkyu8api58tawr/WinAudio.JPG?dl=0) running - so I can only assume the OP has either a). made a mistake, or b). has unknowingly created a "no sound" issue for people who followed the Cziranku's indstructions.

pj

Lane Street
September 13th, 2014, 16:14
Against my better judgement I tried this tweak a few days ago.

As expected I saw no change.

Thinking that this is the kind of tweak that can come back and bite you in the a$$ somewhere down the road I decided that I should revert it today.

Doing so left me with no sound at all.

After spending a while troubleshooting I discovered that you do not "DELETE the "MMCS" part", you delete the MMCSS part.

Trucker, can you fix your post???

cheers,
Lane

Lane Street
September 13th, 2014, 16:16
Sounded good to me - first thing I noticed was no Audio service. Tried restoring the changes but still no audio. This been a problem for anyone else?

See above ^^^^^^^

Devildog73
November 2nd, 2014, 08:34
Semper Fi and thanks Brother!




This was posted by Daniel Cziranku on another site.
After trying it out, I found it worked fantastic, and want to share it here.
Here is what he posted.
--------------------------------------------------------------------------------------------------------------------------------------------------------------------
If you use Windows 7, and you have a strong machine but still have some LAG, low FPS or unstable performance, here's a little trick you can try:
You'll have to turn off Multimedia Class Scheduler in both msconfig, and modify a key in the registry. This module causes fps drop-down, lag, and many more terrible things to our gaming performace. I turn this off on every build of Windows 7, every install.
so, let's get started

STEP #1
1. click on windows key / start menu
2. in the search field type and run: msconfig
3. click on the services tab, and search "multimedia class scheduler". uncheck the checkbox
4. if unchecked, click ok. when asked, DON'T restart your system. do STEP #2 before restarting !
( also, you can go through the "startup" tab's list, If you have something that isn't necessary to start with windows bootup, you can take them out easily here. this can save boot time and memory, too )

STEP #2
1. click on windows key / start menu
2. in the search field type and run: regedit
3. on the left side open the following path: HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > services > AudioSrv
4. click on AudioSrv, and on the right side of the window there will be a list, search and doubleclick "DependOnService"
5. after you opened the little window, DELETE the "MMCS" part. only that part, leave the other 2 alone.
6. if you deleted it, click OK and restart your computer.

ACHTUNG ! you need to go through both step 1 and step 2 in order to fully disable this little imp !
I gladly help anyone who needs it, just drop some letters and I'll reply.

Hope it helps a lot of you, have a nice day !

Naismith
November 2nd, 2014, 13:09
Moderators

I think this thread should either be deleted or a huge warning message put in place.

I tried it out (idle hands and all that :pop4:) and can confirm that it wipes out windows media sound totally (media player cannot play and other sound players fail too e.g. WinAmp :redfire:). Fortunately I am comfortable messing about with the Registry however it is easily corrupted and may cause others trouble :banghead:.

Oh and the benefits for the sim are NIL.

Roger
November 2nd, 2014, 14:11
Moderators

I think this thread should either be deleted or a huge warning message put in place.

I tried it out (idle hands and all that :pop4:) and can confirm that it wipes out windows media sound totally (media player cannot play and other sound players fail too e.g. WinAmp :redfire:). Fortunately I am comfortable messing about with the Registry however it is easily corrupted and may cause others trouble :banghead:.

Oh and the benefits for the sim are NIL.

I agree, there have been a number of simmers who have lost media player with this mod. So here's a big warning:

Don't do it unless you're really confident you can undo it!!!

Lane Street
November 2nd, 2014, 15:30
I agree, there have been a number of simmers who have lost media player with this mod. So here's a big warning:

Don't do it unless you're really confident you can undo it!!!

And that's the big problem.

Can we at least get the typo in the OP fixed so anyone can undo the mod by using the instructions here?

cheers,
Lane

Roger
November 2nd, 2014, 17:51
And that's the big problem.

Can we at least get the typo in the OP fixed so anyone can undo the mod by using the instructions here?

cheers,
Lane

It's fixed!

Lane Street
November 2nd, 2014, 21:55
It's fixed!

Tusen takk!!

OleBoy
November 8th, 2014, 16:53
Has anyone tried this, that is using P3Dv2.4?
Even though I get the occasional spike here and there, I'm hesitant to try it.

trucker17
February 1st, 2015, 18:37
If you only get the occasional spike here and there. I would not try it....

heywooood
March 18th, 2015, 19:03
this tweak works for me. I was having lag spike every time the atc was active...IFR vectors to AI flights were really wreaking havoc with my FPS.

using this tweak has erased that problem / FSX bug completely.

Thank You for posting your find here, Trucker - I think this one is on par with the affinity mask tweak, a necessity for FSX