View Full Version : Heading Indicator (Compass) woes

February 14th, 2013, 18:40
Well, I guess there is a first time for everything.

I have a new computer running Windows 8, and have reinstalled FS 2004. All is well, except now I noticed that my headings are off by 20 degrees on my compasses, autopilots, etc.

Believe it or not, this has been a trying journey up to this post. I'm not going to bore you with the details, but will mentioned that the OS was (or appears) to have been toasted by a virus two days ago so everything got a full reinstall. I have a full copy of all my folders on an external drive and, as I've done in the past, copied them over a fresh FS9 install. A couple aircraft and utilities were reinstalled to register them on the computer, and everything works fine... except for the compass headings.

I've verified this with a couple aircraft, and started the sim with a fresh FS9.cfg file so I suspect that something else got corrupted. But not sure what.

Any ideas on what to look for? Would this be a *.dll or something else since its affecting the compass headings in all the aircraft I load.

Thanks in advance. I sure need to help on this one as I am not looking forward to a complete reinstall. Yuck.


February 14th, 2013, 19:33
Unfortunately, I can't add much except commiseration. I've had this happen to me twice. I solved it,after some random flailing around, by removing scenery until the problem went away. I don't know exactly why that solved it. I added the scenery back after the problem was "solved" and the headings stayed correct. It hasn't occured since. Maybe someone else knows why... I hope.

February 14th, 2013, 19:51
I suggest
C:\Documents and Settings\yourname\Application Data\Microsoft\FS9\facilities
Save first (just in case) and delete the files in this directory
Relaunch FS2004
Check if good and save again as your default flight (if any!)
This seems had worked for me ...
The path can be different for your OS (it's in the same place as FS9.cfg)

February 14th, 2013, 21:49
There may be a number of possible causes but the only one I have encountered ( and solved) was due to a scenery file that had an incorrect magnetic Variation set in it. For some reason, flights near the offending critter, or started near it, or from it would then cause heading indicators to read incorrectly. Sometimes it was instantaneous, sometimes the heading indicator would "creep" out of the correct orientation. I was fortunate that I had only installed and used one scenery addon just before the problem developed so it was easier to check and correct (removal) - it was an aircraft carrier in the Atlantic and the Mag. Var. was set to 0*. Navtech's suggestion may work. If not you might have to consider reinstalling the addon sceneries bit by bit instead of 'massively' and checking each as you go. That way you can identify be elimination ( or is it addition?) - if/when the problem occurs it would be from the last bit installed.

February 15th, 2013, 02:15
I have run into this occasionaly and it turned out to be an error in the saved flight I was loading. I created a new flight using the default Cessna at the same airport and all was well.

February 15th, 2013, 02:42
I've had this before, as mentioned above caused by a afcad with wrong mag variance.
Easiest way is to isolate by halves, ie uncheck half of add-on scenery, see if problem still there, etc, etc



February 15th, 2013, 06:32
Wow. You guys are great. Thanks for all the responses.

Navtech's solution worked. After recreating the files in the Facilities folder, the compass is pointing in the right direction.

February 15th, 2013, 07:59
Mods, this might be a good addition to the Tweaks & Tips bin...

Tom Clayton
February 15th, 2013, 08:57
Mods, this might be a good addition to the Tweaks & Tips bin...

I was just thinking the same thing... :icon_lol:

February 15th, 2013, 17:08
Looks like I was a little premature in my response.

Deleting the files in the Facilities folder did work. However, if I exit and return to the sim, the problem returns. And yes, I did save my current flight after deleting the contents of the Facilities folder.

My current flight is from a stock FS 2004 airfield, Olympia airport (KOLM). When I'm lined up on runway 35, the compass says I'm on runway 1 (about a 20+ degree offset).

I've experimented by removing various addon scenery files, and the results are the same. Once I alter the scenery database and re-enter the sim, the compass headings are fine. However, if I exit and return without changing a thing, we're back to square one. My guess is that the scenery database files in the /Facilities folder are saved upon exiting the sim, so whatever is causing the deviation is saved as well.

Keep in mind that these exact scenery files and other configurations worked just dandy on my Windows XP, and that this unusual situation surfaced only recently after my last reinstall under Windows 8.

Might it be possible for one of the default (vs. addon) sceneries be corrupted??

Thanks again. Looks like its back to the drawing board.

February 20th, 2013, 12:13
Just wanted everyone to know that this thread is not dead yet.

I'm slowly going through my addon scenery and deactivating one group at a time to determine if any specific scenery is the cause of the compass errors. I printed out my scenery.cfg file, and out of the 138 areas I'm down to area 106 - meaning I've only been able to test about 32 addon sceneries.

Each test requires two passes. After I change the addons to include/exclude each scenery, the next time I access the sim the compass is on the correct heading. Whatever is changing things occurs when I exit the sim, meaning it written to the files in the Facilities folder. The second time I access the sim, I check the heading to see if its still off.

I did find some more interesting threads over at Flightsim (http://www.flightsim.com/vbfs/showthread.php?244715-FS9-mag-hdg-problem&highlight=heading+error) having to do magdec.bgl file. I'll likely try that when I'm done checking all the addon sceneries.

February 26th, 2013, 13:50
Well, I almost gave up.

I went through all my addon scenery in groups of 4 to 6 to see if I could find which one was causing the heading error, and did not find anything.

In a closer examination of my setup I discovered I had made an error when attempting to restore my previous setup. After doing a fresh install of FS9 and then copying over my folders, I had forgot to consider that some of the stock *.bgl files were disabled for various addon sceneries. Essentially I ended up restoring the stock *.bgl files which might have been conflicting with their addon replacements. Despite cleaning these up, I still did not find what was causing the heading error.

As a last resort I applied the solution listed at the other forums which is to create a specific addon scenery for the magdec.bgl file. At first that didn't work as I had it in the wrong priority. When moving it to the #1 priority, my headings are as they should be.

I may do a full reinstall someday, but not someday soon.

Thanks for your patience.