PDA

View Full Version : Getting FS9 to keep assignments



SSI01
January 29th, 2013, 12:30
For some reason my copy of FS9 refuses to keep the assignments I've given the sim for certain buttons on my joystick. These change from flight to flight, and I have to keep resetting them to what I want. What could be keeping the assignments from "sticking"?

Daube
January 29th, 2013, 13:18
Did you try to run it by right-clicking the icon and choosing "run as administrator" ?

Dangerousdave26
January 29th, 2013, 15:24
If you are using windows 7 go to this thread post 7 http://www.sim-outhouse.com/sohforums/showthread.php?52003-FS9-Crashes!-%28Possible-compatibility-issues-in-Win7%29&p=779231#post779231

Follow those instructions

If that does not help or you still have XP I have seen where the fs9.cfg file goes wonky and will never save right again. Normally for me it happens when I add a new controller. The only answer is to backup the config then delete the one FS9 is using. Start FS9 and let it generate a new one. Then of course you have to set the whole thing up again.

SSI01
January 29th, 2013, 15:52
Did you try to run it by right-clicking the icon and choosing "run as administrator" ?

Right-clicking the icon for the sim doesn't produce that result.

SSI01
January 29th, 2013, 15:55
If you are using windows 7 go to this thread post 7 http://www.sim-outhouse.com/sohforums/showthread.php?52003-FS9-Crashes!-%28Possible-compatibility-issues-in-Win7%29&p=779231#post779231

Follow those instructions

If that does not help or you still have XP I have seen where the fs9.cfg file goes wonky and will never save right again. Normally for me it happens when I add a new controller. The only answer is to backup the config then delete the one FS9 is using. Start FS9 and let it generate a new one. Then of course you have to set the whole thing up again.

I'm running Windows XP SP3, but haven't changed the controller (joystick). Just something in the very recent past has interfered with the smooth functioning of the sim, but I don't know what. I will try the idea of starting it after backing up the cfg file, and letting it build its own.

SSI01
January 29th, 2013, 18:52
Did you try to run it by right-clicking the icon and choosing "run as administrator" ?

Daube, as it turns out, with a little change, your way works. I use GameBooster3 to shut down background programs and save resources when I am running my sims. FSSW60 is one of those sims. When I back out of FSSW60 after leaving that sim normally in GameBooster, the screen remains black - in other words, it hangs up, and I have to restart the computer. I moved the shortcut to FSSW60 out of GameBooster and onto the desktop. I now get the option to open using "Administrator," although I don't have the password for that. I open it instead using "Owner" plus that password. The sim now opens fine. Going your way, upon leaving the sim I get my desktop back, plus the assignments stick as well when the sim opens. There must either be something wrong with the connection between FSSW60 and GameBooster3, or something wrong with the config file in the sim, as you say.:isadizzy:

Tom Clayton
January 29th, 2013, 19:34
Many people leave the adminstrator password blank when setting up XP. But if just hitting enter when prompted for it doesn't work, here's a list of tools that can help with recovering or resetting your passwords:
http://pcsupport.about.com/od/toolsofthetrade/tp/passrecovery.htm

Daube
January 30th, 2013, 02:35
This "Gamebooster" and other similar tools have caused a lot of stability problems on my computer when I tried to use them some years ago.
As a consequence, I quickly stopped using them, so I don't have many knowledge about them. Sorry I can't help more :/

SSI01
January 30th, 2013, 04:41
Daube, no problems. You provided an excellent suggestion that worked!

Tom, thanks and I'll delve into that when I get back from school in a little while.

Oh, and I'm saving these little hexes and fixes in a text file in a "Tips and Tricks" folder. I want to keep them around.

Tom Clayton
January 30th, 2013, 07:27
Tips and Tricks - good idea! Moving...