PDA

View Full Version : Odd Wireless Connection Issue; WinXP



Lionheart
July 5th, 2010, 10:30
Hey all,

As you know, I run on an iMac computer with dual boots of Mac OSX and Windows WinXP. My rig has a built in WiFi wireless system. It normally talks flawlessly with the Motorolla modem/router (both in one) system. However, the past month, I have to restart my wireless system in Windows mode, sometimes continuously, like every 5 min's, and sometimes, not one time in a day, which leads me to think its possibly a next door issue, perhaps frequencies overlapping? I dont know.

To quick fix it, I right click on the Wireless icon on the bottom right tray, select 'View Available Wireless Networks', then 'Disconnect', then 'Connect' again. I have security set in the Modem with password. I think this morning, so far, I have reset it about 8 times.

Has anyone else had this problem? Is there a work around? Oddly, the system is fine in Mac mode, running in Apple. This has never happened before and only recently started, and no one else in the house has this issue.

I just made an observation. As I was writing this, it went offline, and then went back online on its own, which I have seen it do in the past.

Wierd....

Bjoern
July 5th, 2010, 14:23
Put anything between router and desk recently? Or relocated the router?

A friend of mine has the same problem.

Are you using WEP encryption?

robert41
July 5th, 2010, 19:21
I used to have wireless internet on my old computer. We have 2 computers at home, running off a wireless router router. Mine was the wireless hook up. Had nothing but problems with connecting. It would work fine for a time, lets say a month or so, then it would do exactly the same thing as your having right now. This start and stop connecting might last a week or two, then everything is fine again for a while. I tried adjusting the antennas and moving the router to different places, but the cycle continued. 99% of the time it would reconnect so I lived with it. Finely, after 4 years, the router quit working entirerly. I picked up a new router and ran a network cable to the computers. Not a problem since.

capun
July 5th, 2010, 19:39
One problem that you may get if you use the WindowsXP Default WZC (Wireless Zero Configuration) is that the WZC searches continously for active wireless networks and gets lost.

A workaround is to disable the WZC once you have a wireless connection. This problem is usually fixed by 3rd party wireless network managers from Linksys, Netgear, Intel, etc.

Create a batch file containing just the command:

C:\windows\system32\net.exe stop wzcsvc

Save the batch file in your desktop, name it something like KillWZC.bat

Also create another batch file to re-start the WZC if you need it, with the command:

C:\windows\system32\net.exe start wzcsvc

Save it to the desktop with a name like StartWZC.bat

Here's a link to MS

http://msdn.microsoft.com/en-us/library/ms706593(VS.85).aspx

Moparmike
July 5th, 2010, 19:58
Yup, as capun posted, it sure sounds like the WZC hiccup that plagues some machines. I think it's hardware related to whatever brand router you're using and it's chipset.

My laptop had the same problem when I was using a D-Link router (I forget which model). After I switched to a Linksys WRT54-family router I haven't had the problem at all anymore.

If you've got another router available, give that a try. If not, you can use the start/stop shortcut trick that is outlined in the MS Technote that capun linked. I don't know for sure if you can double-router that Motorola combo unit that you've got...I wouldn't see why not. Also, check for a firmware update for your modem/router...DLink had several firmware updates for the problem-child router that I have but none of them cleared up the WZC connection dropping issue for me although others had posted (on various tech forums) that it worked for them.

robert41
July 14th, 2010, 19:47
That WZC issue could very well have been my problem. My old computer was XP. The router was an Linksys wrt54g. I chose this model because we have one at work that works perfecly well. All water under the bridge now.