PDA

View Full Version : OpenSolaris and wireless



aeronca1
January 16th, 2010, 13:49
OK folks, this is a strange one on me. I've never encountered this before. I have an older Toshiba laptop that was running Windows XP Pro just fine until recently. After some updates, it wouldn't boot. OK, I says to myself, time for a fresh install anyways (I deal with a ton of beta and test software in my job).

Restore CD in boot drive, install goes fine and voila? Nope, no boot. Nothing I did worked...

So says I, let's go to another OpSys. In goes various flavours of Linux and after many installs, I like OpenSolaris. I'm using release 2009.06.

So far, I only have 3 problems. I use a Linksys WPC300N PCCard for wireless and can't find a driver. USB keys also don't get mounted and lastly, no FlightSim....

I can't do anything about the latter, but any advice about the NIC or USB key would be greatly appreciated.

Matt

Moparmike
January 16th, 2010, 15:56
Hmm...I've had to fight with the wireless card on my Toshiba lappy too with Mandrake, Debian, & Vector. Never tried OpenSol.
Mine has the built-in Atheros chipset (IIRC) and that one is a bugger to set up the driver for. Any idea what chipset that PC card uses?

Just for giggles, have you tried a Ubuntu live CD? Ubuntu is the only distro I've tried on that rig that found my wireless chipset "right out of the box". I have to stick with the LAN cable when I run Debian on it.

On the USB keys (flash drives?)...
You'll probably have to mount them each time you plug them in. Am short on time and don't have my laptop handy at the moment to get at my mount script. (Ubuntu has made me lazy...I can't command-line right of the top of my head like I should to be a true Linux geek! :d)


Maybe try snooping around over at http://www.justlinux.com/ in their forums and.or help file library. There are a lots of how-tos and guys running assorted distros & hardware over there that might be able to help ya out.

aeronca1
January 16th, 2010, 17:12
Thanks for the link!

I've been snooping around all day today, and found the almost any flavour of Linix really dislikes Broadcom based WiFi cards. Soooooo, into the box wifey keeps threatening to toss and pull out an old "B" card that OpenSolaris is supposed to support from the get go. Well, it recognizes the card, tells me there are several WiFi networks seen, but as yet it won't connect. Closer, lol! As for my N card, it looks as if v2 works but not v1. Different chips apparently.

The driver for the USB key is loaded, but it doesn't want to mount. Time to leave it for the evening, go flying, then watch a movie. Hope all the "chick-flicks" were rented out... Shhhhhh, that could get me on latrine duty...... :salute:

As for Ubuntu, I have tried it as well as Kubuntu, but it also fails to see the newer WiFi card. So far, I'm really liking OpenSolaris. If only it didn't have the Gnome interface. I "grew up" on KDE.

EDIT: Ooops, forgot to answer your Q. Apparently the Atheros chipset is well supported in OpSol. I have never had that particular chipset, so beyond what I've read earlier, I plead ignorance. It seems that the Intel chipset is the best supported, but I also have no experience with Intel WiFi.