View Full Version : Scenery problem and solution.

February 25th, 2009, 09:25

While starting up fsx the "Loading terrain data" window seemed to be stuck, then advanced slowly to about 31% and aborted. Windows did an analysis and provided some file names that might help and provided their locations as:



Could not find these files, even with Vista search. I guess they got erased.


Since it seemed some files were loading ok, I went into the library and deactivated all the 100+ sceneries I had loaded and none of those that came with fsx. FSX then worked. I then reactivated the sceneries I had loaded in 6 batches. After each reactivation and with all reactivated fsx worked.

I don't know what the problem was but perhaps the scenery.cfg file was messed up somehow and got fixed in the procedure described above.

February 25th, 2009, 09:41
Sounds like you couldnt find those files because you did not have "Show hidden files" activated. Good to hear you got it fixed tho. It sucks when you have so much good stuff in FSX and it starts crapping out on you.

February 25th, 2009, 11:06
When you have a loading problem with FSX, allways re-boot.
If you still have a problem, try de-activate the last scenery that you installed. That includes any AFX file. These can cause a problem as well as scenery.
My 2 cents.

February 25th, 2009, 12:34
Thanks for the advice, Joe. I did reboot a couple of times without success, but did not know of the reactivate the last scenery installed trick. Hope I can remember should this happen again.

February 25th, 2009, 15:58
Jim I love your st louis scenery and would like to know if you are going to add any more sections to it.

February 25th, 2009, 16:36
Dang, the scenery problems arose again. So I've now looked at the scenery.cfg file located in:

c:\Program Files\Microsoft Games\Microsoft Flight Simulator X\
My question is: Is there another scenery.cfg file somewhere? I ask this question because:

1) I've changed the scenery in the library several times today after a failure, and once got it to work sucessfully but the date of the scenery.cfg file is still days ago (2/19/09).

2) The entries in the scenery.cfg file don't match those in the scenery library. All the default files appear in both the scenery.cfg and library, but only a few of those that I have added and appear in the library don't appear in the scenery.cfg file.

3) I've recently activated one of my files in the library and it works, but the scenery.cfg file did not change.

4) An attempt to deactivate all my files and reactivate them as I had done before and got it to work sucessfully now fails to work.

5) The mystery deepens when I examine a backup of the scenery.cfg file done days ago. It is identical to my current scenery.cfg file.

If there is another file that controls the scenery, this may explain some of these strange happenings, thus my question about another scenery controlling file.

February 25th, 2009, 16:41
Jim I love your st louis scenery and would like to know if you are going to add any more sections to it.

I had not considered doing more, thinking that the area covered was sufficient. Guess I was wrong. If I do more, was there a particular area of interest? I believe there is more USGS data available but I can't tell you off hand how much or where.

Holger Sandmann
February 25th, 2009, 16:48
Hi Jim,

the active scenery.cfg is in C:\ProgramData\Microsoft\FSX . The one in the FSX root folder is just an inert backup of the default though I've seen at least one add-on auto-installer add entries to it, which seems rather odd.

Cheers, Holger

February 25th, 2009, 16:53
Jim any direction you want to go I enjoy it all. I bought a section of mega scenery earth for the seattle area and I like the way your st louis scenery looks by far over the payware. :ernae:

February 25th, 2009, 17:06
Thanks Holger. That must be why it appeared the files were not being updated. Obviously other things are going on which I will investigate.

Vista has failed me again on searches. Apparently if I focus on a root drive and do a search it will not find all the files in that drive. When I searched in the Program Data folder, low and behold the controlling scenery.cfg was found.

Shylock, scenery.cfg is not a hidden file. The above paragraph explains why.

February 25th, 2009, 19:00
After copying a backup scenery.cfg file into the correct location, all seems to be working again. Comparing the current scenery.cfg file that failed and the backup did not demonstrate remarkable differences.

Both failures occured after attampting to load a new plane. Under suspicion is the fact that instead of loading 3 .cab files into the gauges directory of fsx, I loaded them into the panel folder of the plane. I have no proof this was the problem, but I don't intend to try that new plane again.:icon_lol:

February 25th, 2009, 19:22
Thats why I use a test rig..........LOl its saves headaches.....:faint:

So glad you have it going again...

March 1st, 2009, 13:52
Famous last words.... It's fixed. Well it wasn't. The very next day after the last post the system failed again.

Deactivating all but the default sceneries and running FSX was successful. And activating them all afterwards again was also successful. But on occasion when a plane change was made, that would cause an fsx failure and scenery loading would again fail.

1) Scenery was reativated in groups, beginning with the first half of 100+ sceneries in the library. This was tested and if it failed half of the remaing sceneries would be reactivated. This was continued, a sort of binary search, until scenery would load again. Finally one scenery was found that caused the error and deactivated. From that point on it seems to have fixed the problem.

2) Reviewing the faulty scenery via MS Explorer one of the subdirectories was found to be corrupt and was unable to be deleted via Explorer. Went to a command line and attempted to delete it and was informed to do a chkdsk. Following that op it was possible to remove the faulty directory and files.

It's fixed!:jump:

March 1st, 2009, 14:20
Thats a lot of headaches Jim...:applause::applause::applause: