View Full Version : Help needed please.

October 8th, 2008, 11:05
I have just developed a problem with FsX I have never had before. When I start up FsX and get to the aircraft preview screen it is black. All the other menus and buttons are there. If I choose to fly from the screen the whole screen is black. There are sounds but no top menu when pressing Alt. No right click menu either.
I have built a new FsX.cfg...same thing. I have edited the FsX.cfg to return to non-Dx10 preview mode (ie Dx9c) same thing. I have not yet tried reinstalling the Nvidia drivers and do not want to reinstall FsX and Acceleration unless it is my only chance.

Anyone any ideas?

October 8th, 2008, 11:56
Tried reinstalling the video drivers then when that didn't work tried a restore point to yesterday. Still the same.

Bruce Thompson
October 8th, 2008, 11:59
Hi Roger ,

What addon did you load last, i.e. in the last 24 hours?

October 8th, 2008, 12:01
Hi Bruce,
The Alphasim Badger (which I've since deleted) and that's it.:isadizzy:

October 8th, 2008, 12:07
Are you sure your Nvidia card ain't starting to go south?I've seen simular when cards start to go bad.

October 8th, 2008, 12:15
Are you sure your Nvidia card ain't starting to go south?I've seen simular when cards start to go bad.

It's possible but there are no other graphics issues. This is crazy:isadizzy:

October 8th, 2008, 12:20
Fullscreen or windowed mode? Try to switch between both modes.. try also to switch between the different views (2D/VC etc) and disable and enable AA.

Do you use nhancer? If so, try it without and set AA and AF to app controlled.

October 8th, 2008, 12:31
Hi Nils,
I've tried windowed and full screen. I can't get to the main graphics settings because I don't see a menu in free flight. I've tried running a mission and I've tried various settings in the Nvidia control panel and I don't use Nhancer. Looks like a reinstall of FsX but I'm not in the mood to try that yet...maybe in a week or two. I'll just have to manage without my FsX fix for a while.

October 8th, 2008, 12:41
OK didn,t know all other games worked fine,kinda rules out your card.

October 8th, 2008, 12:47
I think something similar happened to me when I had my nvidia card settings set to force AA or AF, can't remember, might want to look at that?

kilo delta
October 8th, 2008, 14:15
When uninstalling an re-installing graphics drivers it's well worth using a drivercleaner program in order to rid the registry of the old graphics settings and values. Try these...


October 8th, 2008, 14:38
You try a system restore yet?

October 8th, 2008, 14:45
Kilo Delta,
Yes I use Driver Sweeper every time I install a new video driver.

I have tried a restore to yesterday but the problem remains.

So it maybe a Vista issue or an FsX issue or a Video card hardware issue. If only there were a software problem detector.

October 8th, 2008, 15:51
Oh well I give up. I needed to get out more anyway:costumes:

When technology gets away from you and there seems no way to understand what a split second failure is caused by or what the remedy is, it's time to go "Kiss" (keep it simple stupid) and take up a simpler, less demanding pursuit like stamp collecting or diy. The truely annoying thing is the lack of good debugging programs so Vista and FsX can sort themselves out, or at least offer suggestions as to a solution. As it stands I have a great investment in hardware and software that is so much junk when it fails.

October 8th, 2008, 16:37
try setting AF and AA to force and set them at 2x, on my rig i had problems using anything higher

October 9th, 2008, 15:46
Here is my preview screen. The windowed or full screen is the same. Fs9 is fine in either mode. Any ideas greatfully recieved.


October 9th, 2008, 16:09
Hi Roger, go to you video card setting for your computer and set the AA and AF to default, matter of fact set all the settings to default, if you have Rivertuner or the other tweak settings program turn them off or reset to default....reboot..post what happens..Mike

October 9th, 2008, 16:13
Yep, that's the same screen I got when I was forcing AA and AF, I leave those to default also and use the game AA and AF.

October 9th, 2008, 16:21
Yea that happen to me a few years back...lol...can drive ya nuts at times:costumes:

October 9th, 2008, 23:17
Thanks for the replies fellas, but AA and AF are set to enhance! I'll give it a go when I get home tonight...you never know.

October 10th, 2008, 00:35
Thanks for the replies fellas, but AA and AF are set to enhance! I'll give it a go when I get home tonight...you never know.

That sounds like it Roger, good luck.

October 10th, 2008, 01:44
Roger what card do ya have and are you using beta drivers for the card or WHQL ?

October 10th, 2008, 03:21
Roger what card do ya have and are you using beta drivers for the card or WHQL ?

Hi Moe,
I'm using an Nvidia GF8800GTX with the same WHQL drivers as before. They're the 177.* series drivers from the Nvidia website...had 'em a month or two now.



October 10th, 2008, 03:47
is it only that plane roger or doese it happen to all of em?? (if it worked with that plane before then ignore this :))

October 10th, 2008, 07:49
Tried FsX with minimal settings, no AF and X2 AA and still the same black screen:banghead:

October 10th, 2008, 09:31
There were some very informative thread shere about the correct way to uninstall FsX/Acceleration/add-ons but these threads have all gone now with the SOH server crash. Can anyone point me to a thread on another forum or post some info here.


October 10th, 2008, 09:38
uninstall Acceleration
uninstall FSX
delete FSX folder


October 10th, 2008, 10:09
Thanks Stiz, but should I uninstall 3rd party programs (Like aircraft & scenery) first?

October 10th, 2008, 10:18
i dont tend to, but then i install to a seperate addon folder and then drag n drop, if you install straight into the fsx folder it might be worth while :)

October 10th, 2008, 14:00
Roger, install this>>> http://downloads.guru3d.com/Guru3D---Driver-Sweeper-(Setup)-download-1655.html remove the old driver, boot into safe mode, run that sweeper program, reboot and install current driver, also download and reinstall DX 9, If you are running in DX10, uncheck it....Mike

October 10th, 2008, 15:39
Hi Moe,
Done that as I have Driver Sweeper and always use it prior to installing a new video driver in safe mode. I've also reinstalled Dx9c but I can't uncheck Dx10 preview because I can't see the menu in freeflight. The "Settings" menu which I can see doesn't offer the choice of Dx10 preview mode so I can't uncheck it. The FsX.cfg mentions D3D10=1 which I changed to D3D10=0 but still no effect.
I really appreciate your efforts but I think it's now a FsX uninstall issue.

October 10th, 2008, 23:51
I really appreciate your efforts but I think it's now a FsX uninstall issue.

Rather than a complete re-install, try a "repair" from the RTM DVD then from the Acceleration DVD with a run of FSX in between. This should preserve your add-ons.


October 11th, 2008, 03:34
Well George,
I had no confidence in your "Repair" suggestion but tried it anyway. I believed it had failed when I tried to run FsX after the FsX repair had gone through it's routine and FsX would not run, throwing up error messages. So I then ran an Acceleration repair...and It Bloomin' well worked!!!

George, you sir are a "Steeley eyed missle man":ernae:

Thanks to all who offered their suggestions, I am most grateful.

October 11th, 2008, 05:01
I'm glad to see you're back up and running Roger :applause:


October 11th, 2008, 07:59
Glad you are back up and running Roger!

What a wild journey... arrghh...